VideoScribe Help

Topic not covered?

Start a new topic

imported SVG line art not rendering correctly

I am using the 7 day trial.  

I've imported my own line art (created in Adobe Illustrator - saved as SVG). But when drawn in VideoScribe, the lines of the line drawing are outlined first, then filled with black. (FILE ATTACHED) I'd like to have the drawing actually look like it is being drawn... but how? Any suggestions?

Thanks for attaching the files.

I see the problem. Unfortunately, importing a jpg into inskcape and just saving it as an SVG accomplishes nothing useful.

your options:
1) EASIEST OPTION: just import the jpg directly into videoscribe and select one of videoscribes drawing options or
2) OPTION THAT PRODUCES THE SMALLEST FILE SIZE, SIMPLEST SVG THAT VIDEOSCRIBE LIKES BEST: import the jpg into inkscape (use version 0.48.5, not the newer version) and manually trace all of the black lines with either the pen or pencil tool to create basic black stroked paths, then delete the jpg and save the SVG or
3) OPTION THAT IS THE MOST COMPLICATED BUT DRAWS WELL (IF DONE RIGHT) AND MAINTAINS THE LOOK OF YOUR ORIGINAL SKETCH: do step 2 above, but KEEP the JPG in the SVG and change the opacity of all of the stroked paths that you drew to 0% (FILE SIZES TEND TO BE BIGGER, MORE OPPORTUNITIES TO MAKE MISTAKES, MAY CAUSE EXCESSIVE MEMORY USE) or
4) hire a more experienced videoscribe artist to help make your SVGs


It is probably best to start with the simplest methods if you are having trouble. then try more complicated methods as you become more familiar with the software.

 

MORE SVG TIPS and longer explanations: Making SVG Images Draw Well (2015 update)


-Mike (videoscribe user)

Thanks a lot Mike for taking the time to answer my question. Your insights will be certainly useful. Still it's a mistery why the first image I have converted into SVG worked perfectly. Have a nice day! Cheers

 

Hi everyone I am having a problem with an SVG that I created in illustrator. I traced it with the pen tool as recommended with 2 point stroke. When I run it in Vscibe it animates perfectly but the lines are very thin and nothing like the final image. Photo one is the line thickness during animation and the photo two is what the final image is supposed to look like...I have tried pushing the default image quality up but the result is the same.

image.jpg image.jpg
6.98 MB
image.jpg image.jpg
5.24 MB
Hi,
Default image quality affects how blurry or sharp your images are, but  it would probably have no effect on this type of issue.  where there is a problem in the way the SVG is prepared. Note: Higher quality settings will increase your memory usage so don't set it too high. I keep mine at about 1000 unless some images look blurry.

The screenshots help, but as always, please attach the SVG if you want help with the SVG.

-Mike (videoscribe user)

 

Hi Mike I don't have issues with quality, the image displays just fine. Its that during animation where it should be making a solid line it creates like a double line which is very thin. I'm sure I am making the SVG wrong somehow, I am a video editor by profession so my knowledge of Illustrator is very limited. Attached is my SVG


When I open your SVG, all of your reveal lines are filled paths instead of stroked paths.

7mfKqkPDVEKwbU1xs46c5iYqFLdCT-OdcQ.jpg




I don't know if you are using the wrong tool, or the wrong save settings or something else.

It looks like you are using the paintbrush or the blob brush tool instead of the pen or the pencil. 

what version of illustrator?

If you are using illustrator CC, use the save settings mentioned in the following thread:
Making SVG Images Draw Well (2015 update)

-Mike (videoscribe user)

 

Ah ok thank you Mike I will try your recommendations and get back to you. I am using illustrator CC 2017. But given that i never really work in illustrator that is definitely the kind of mistake that I see myself making.


Login to post a comment