VideoScribe Help

Topic not covered?

Start a new topic

svg file won't scale

I custom built images and they look great as svg files and are scalable in other programs. However as soon as I take them into Videoscribe I can not resize them without them falling apart.


Any ideas?  Cant get a clean image.

Hi,

What do you mean by "falling apart"?
Attaching the SVG to your post would be a good idea.

also:
http://help.videoscribe.co/support/solutions/articles/1000033754-videoscribe-v1-tutorial-creating-your-own
http://help.videoscribe.co/support/discussions/topics/1000031362

-Mike (videoscribe user)


 

I tried attaching it and it wouldnt post. I will try it here again.


when I say "falls apart" I mean the moment I resize it it looks terrible (low rez)


The svg file looks fine to me but I dont know much about svg.  As soon as I put it in Videoscribe resize it, it looks terrible. Am I missing something?  

Hi Raul.
581 KB is a pretty large file size for an SVG, which may indicate some issues. I'll take a look at it and see if I can offer any suggestions.


-Mike (videoscribe user- not official support person)

 

Videoscribe has no issue with drawing the image. The image just looks low rez once I get it into videoscribe.

thanks Mike!


testing...

 

Oh yeah! I see what you mean. It imports very small and looks very pixelated and blurry when you scale it larger! Still testing the following suggestions and then I will come back and update my post:


1) general note: Delete hidden layers to reduce your SVG file size and improve overall performance. In this case, one of the hidden layers contains a dot that is outside of the upper left corner of the image causing the SVG to import at a smaller size. (The layer is named "Layer 5") removing that will cause the SVG to import a bit larger and sharper.


2)my second suggestion did not seem to help, so I am removing it.


3) you can change the default setting for SVG import quality: VideoScribe version 2 has a default image quality setting for all images. You can change the default (400) by closing all scribes and then selecting the 'Settings' (cog) icon on the project screen. A higher value (maybe 600 or 800 or 1000) may improve overall image clarity but may also increase memory usage.


4) even with the hidden layer deleted, your drawing has over 18,000 points which is kind of a lot. If you are using autotrace to convert line drawings, you may be able to play with the settings to get fewer points without degrading the appearance of the images. Fewer points will mean a smaller file size and a smoother faster videoscribe session.



In the attached SVG I deleted the hidden layers and used object>path>simplify to reduce the number of points by about half. That should help but you may also want to increase the import quality if it is still at the default of 400.



Hope that helps,

-Mike (videoscribe user)


thanks Mike. I increased the file size in settings and that worked. 


You are a life saver. Thanks!!

glad to help! Keep up the good work!

 


Login to post a comment