VideoScribe Help

Topic not covered?

Start a new topic

Intersecting lines appearing in Videoscribe from Inkscape imports

Hi All,


I've searched the forum and same issue has been solved before in Illustrator but not Inkscape as far as I can see.


Please see the attached - first screenshot shows the intersection points appearing before the lines that cross the horizontal are drawn. Second screenshot shows completed scribe.


All help very gratefully received.


Cheers,


Simon


 Hi,


Did you make the SVG or did someone else?

If someone else made it, or if there is a possibility it was made with AI CC then resave it using inkscape.


if you are using a zero opacity stroke then it's too big.


upload the SVG for specific feedback.

-Mike (videoscribe user)

Hi Mike,


Please find attached. I created in Inkscape.


Thanks for your help.


Cheers, 


SB


Hi Simon,


which tools did you use to create that image? There were no strokes set on the lines of your image.



I have used Inkscape to create another similar image using the 'Bezier curve' tool and it does not exhibit the intersecting line issue.


Please find the file I created attached.


Hi Matthew,


I used Inkspace and Bezier tool too.


When I look at the stroke in Inkscape I see below so stroke set?




The SVG draws in the same order I drew the lines in Inkspace but intersection marks remain and also it is much more 'jerky' than your SVG example. So I need to fix so is as smooth as yours somehow too!


I'm new to Inkscape and Videoscribe so please bear with my newbieness!


Cheers,


SB



If I import your SVG into Inkscape and then save and then import to Videoscribe I get the issue again even with your SVG. However if I just import the SVG file you provided straight into Videoscribe then no issue. I'm very confused...

Same thing happens when I draw freehand line with pencil tool

I have now tried drawing the lines on different layers and makes no difference.


Pulling my hair out!

Hi Simon,


I have produced a screen capture where I take you through the steps to make the same file that I attached in my previous response.


At a part of the video you will notice that I select the nodes of the line and add some extra one in between. At this part you need to use the 'Edit paths by node' tool , click on the first node, hold shift and click on the second node.


Please let me know if the video is helpful.


Simon, did you ever figure out what the problem is. It's odd. If I start with Matthew's file and save, all seems ok. But if I start with a new file, I have the intersecting line problem.


I can't see any obvious difference between the way the lines are drawn.

If I start with Matthew's file, delete the images, and draw (or cut and paste) images in, then save, all works ok in videoscribe. However, if I start a new Inkscape file, and draw or cut and paste images in, then save, it gives the crossing lines.


There is a  setting embedded in the file that appears to have some type of impact.

 The problem seems to be a result of the updated pen/bezier and pencil tools and certain save settings in adobe illustrator creative cloud (and possibly newer versions of inkscape that have been updated to reflect the newest enhancements in illustrator).

Resaving the same SVG in an older version of Illustrator or inkscape strips out the problematic data and makes the SVG work correctly in videoscribe. The thread linked below provides more information about the problem and shows save settings that (I THINK) can be used in CC to avoid the problem:
http://help.videoscribe.co/support/discussions/topics/1000033902/page/2


Hopefully there are matching settings in Inkscape that will work the same way.


Otherwise, I would recommend using an older version of the program if possible.


-Mike (videoscribe user)

 (a similar symptom can occur, in any version of inkscape or illustrator, if you are using a zero opacity reveal stroke to reveal line art in your SVG, and the reveal stroke is too wide so it reveals a bit of the intersecting lines or other lines that happen to be very close to the line that is being revealed.


That explanation may not make sense if you are not familiar with the process of using transparent reveal strokes. If you don't understand it, then it probably does not apply to you because you are probably not using that method.)


If this reply or my previous reply do not seem to provide you with a solution, you may want to attach your problematic SVG to your next reply.


-Mike (videoscribe user)

I am not intentionally using zero opacity reveal strokes. My process is:


- I have version .91 of Inkscape

- Load, File, New

- Without changing any default settings, draw with either Pen or Bezier tool

- Save

- Load into Videoscribe

- Problem occurs


Alternative, I can take Matthew's file above and:

- Open Inkscape

- Load Matthew's file

- Draw using Pen or Bezier tool (or paste in what I drew from above)

- Save

- Load into Videoscribe

- All is ok


I have tried in Inkscape saving as the default Inkscape svg, the Plain svg, and the Optimized svg. None work if I start from File-> New.


I can upload my own file, but it is the same problem as described by Simon above.


A work around appear to be to always start with Matthew's file above (Thanks, Matthew) and draw into or cut and paste into that. It's a little annoying, though, to have to do this and have no idea why.


As I mentioned, if you cannot find settings in your save options that fix the problem,
you may want to try a previous version of inkscape. Version 0.48.5 is available here:
https://inkscape.org/en/download/

-Mike (videoscribe user)

 




Login to post a comment