VideoScribe Help

Topic not covered?

Start a new topic

SVG import question

I've posted in the past about problems with imports. In most cases all seems to be working out okay, but here's one (see attached) that draws thin and instantly expands to thick. Could someone tell what what needs to change with the export of this image from illustrator to make it draw at the correct thickness from the beginning?

Hi,

 


-Mike (videoscribe user)

I tried this and it worked to solve the thickness change in the line, but it created another problem. Now when the line is finished being drawn it blurs some.

I have read various suggestions to avoid the sometimes subtle, sometimes noticable blur when videoscribe completes an SVG drawing and replaces it with a raster copy:

I haven't thoroughly tested all of the suggested solutions which include: set your stroke size to pixels instead of points, use thicker stroke size, possibly use a single stroke size, use a document size of 1024x768 or other 16:9 ratio size, (and maybe there are other suggestions).

In a recent test, making SVGs in which the actual image is roughly a 16:9 ratio seems to prevent or at least greatly minimize the amount of post-draw blur:

 

image 1: (from a previous thread) original SVG made in Illustrator CC 2104

image 2: Same SVG opened and re-saved in Illustrator CS4

image 3: 3 copies of the same stroked path with different stroke sizes saved in CS4


these MAY have been made using pixel strokes instead of point strokes, but I don't know if that is a factor or not. The document size was not 1024x768. I think it was A4 or some other default .


Mike (videoscribe user)

 

This is exactly the kind of thing I'm experiencing with other vector graphics I've created with Illustrator CC. 

I don't know if you feel that there is an unacceptable amount of blurring in my video or if you are referring to another problem like the intersecting line artifacts.

-Mike (videoscribe user)

 

The video you provided shows a problem with the lines imported from Illustrator CC vs then ones imported from illustrator CS 4. That would be the line artifacts and I'm experiencing that too with some imports. Additionally image 2 does have some blurring after the drawing of the line, but it's hardly noticeable, but drawing 3 or the final drawings have no blurring that I noticed. Since I have CC and not CS4 how can I export and achieve such quality as in CS4?

 1) to avoid the artifacts, use the SVG save options in the screenshot I provided in my first reply. Once you are using those save settings, there should be no difference between a CC SVG and a CS4 SVG (I think).

2) to reduce the blurring, I'm not sure that there is a guaranteed solution, but my suggestions are in my previous reply. I would also comment that when you scale images larger after importing them, they tend to get a bit blurrier, and when you scale them smaller they tend to be a bit sharper.  importing an SVG with 16:9 proportions and keeping it fairly large on the canvas, seemed to result in minimal blurring in the tests I did. You may have to experiment a little or search for other threads on the same topic if you want more suggestions.

I hope that helps,
-Mike (videoscribe user)

 

What's the difference between sag 1 and 1.1?

Does it matter if "preserve illustrator compatibility" is checked?

What about decimal places? Does it really make a difference in your opinion if that is high or low?

Hi

I think I'm having the same problem.


I'm working with an .AI file with all the illustrations and I copying to another file (300 DPI, 1920x1080, I tried pixels and points as stroke size, tried changing 1 to 7 decimal places...) and what I'm getting is two different quality results on VS as you may see on the file I'm sharing.


I have used the same size on the SVG file so I don't know what else I could do... 


Thanks


Hi,
I'm not sure based on your screencaps or description. It looks like the blurry one might have been imported at a smaller size (or with the camera zoomed in further maybe) and then scaled larger.

You could attach the SVG images here if you want specific feedback on them.

-Mike (videoscribe user)

 

Hi Mike

as you may see those are the SVG files I used and the result on the VS.


Thanks for your help,

Daniel


 when I import those threee SVG images into videoscribe 2.2.5 I get this result (no problems) :

you can right-click the image and choose "view image"(or use the equivalent commands on a mac) to view it larger.

1)  Have you tried deleting the third image and importing it again ?

2) if you have made more than one version, make sure you are importing the NEWEST file and not just re-importing an old cached version from "recently used images"

3) customer support may have other suggestions.


-Mike (videoscribe user)

Hi Mike

I have 2.3.3 version, the newest.


I passed every image to a smaller size on Illustrator (960x560) an maximize the quality on VS and it worked very fine.


But now I must do everything from scracth.


Thank you for your help!


Login to post a comment