VideoScribe Help

Topic not covered?

Start a new topic

Stroked paths when morphing

Hi, I am trying to 'move' an object across the canvas using Morph. My SVG has black outlines (stroked paths) and colour fills. I understand that the colour disappears during the morphing – no problem – but my outlines also become very thin. 


When I try this using VS's stock images, the black outlines remain unchanged during morphing – how do I do that?! I am attaching my SVG.

I can't open it in my older version of AI, but I can view it in videoscribe.  I used DRAW as my animation type to see how it behaved and it looks as though the only basic stroked paths in that file are very thin lines. The thick black lines you see are probably either:
1) a style or effect that has been applied to the thin black stroked paths (that does not work well with videoscribe) or
2)  color fills (or paintbrush strokes) that completely separate from the thin stroked paths and are merely shaped like big stroked paths.

When morphing, all those big black fills (or styles or whatever they are) disappear and only the thin stroked paths can be seen.

If you want to use morph, you will need to open that SVG, and fatten up those thin stroked paths, make sure they are simple basic stroked paths, and probably just delete the big black fills (or the special style or effect or whatever they are) since they will be redundant.

also be sure to use the save settings in the following thread if you are using AI creative cloud: Making SVG Images Draw Well (2015 update)

-Mike (videoscribe user)




 

Hi Mike, thanks for the quick response. Curious... but my black outlines were just basic, uniform stroked paths, with no effects or brushes. But I stripped them all back (Appearance > Clear appearance) and reapplied the colour/weight. I also read the "Making SVG Images..." thread that you mentioned and changed my settings accordingly... and now my images are morphing correctly! Hurrah! ;-) So I'm not sure whether it was my save settings or just a glitch somewhere – but problem solved. 


Thanks so much for your help :-)

Great! Good job.
If you use Adobe creative cloud, the problem most likely had something to do with the updated pen and pencil tools which add some new data to vector graphics that videoscribe doesn't quite know how to decode. The save settings mentioned in the previous link serve to strip out that new extra data resulting in a smaller file size and a simpler SVG that videoscribe (or at least current versions as of May 2016) likes better.

For anyone else reading this thread:New versions of inkscape (newer than about 2013) cause the same problem and do not have save settings (as far as I know) that will strip out the extra data. The solution is to install and older version of inkscape or possibly to resave the finished SVG using software that optimizes SVG images for web use.

-Mike (videoscribe user)

 


Login to post a comment