VideoScribe Help

Topic not covered?

Start a new topic

I'm done with it...

I'll just say that the software is poorly designed and buggy. They really need to design a new timeline system because after you have all of your assets in place, it takes FOREVER to set-up proper timing and animations. 


I honestly could have done this in After Effects in half the time. 


Just venting because it's 4:30 PM and I want to go home, but still got 3 hours to tinker with this bullshit.


Anyway. 

Hi Andrew,


I'm sorry to hear that you are having a frustrating experience. If there is anything in particular I can help you with regarding adjusting timings (or anything else) please let me know.

I have used VideoScribe for a number of years, but I am now actively shopping for alternatives. The video went together fairly smoothly, but once I tried to render, the elements stuck together and the timing was off. I finally resorted to recutting the entire video (pain in the butt), and the SAME THING happened, though in different places. I still haven't posted, and I have an event coming up.


I'm sorry to drop VideoScribe, but it's become too much of a hassle to work around its bugs.

There is probably one simple issue causing all of your problems. You could save your work to the cloud folder and raise a ticket if you want customer support to help you.

-Mike (videoscribe user)

 

Thank you for your input - I did send a ticket and hope to hear back in a timely fashion. I would LOVE to learn there's a simple fix.


Login to post a comment