Select Multiple Elements (v2)

  • Hello,

    We used to be able to select multiple elements (and then set the camera, change the position, etc.).

    I thought that feature would be part of V2, but it doesn't seem to be.

    Will that be re-introduced? Am I doing something wrong?


  • Hi Jonathan,

    Yes, this is a feature of version 2.0 - select an item on the timeline or on the canvas, hold down the Ctrl key and click on another element to select that one as well or hold down the shift key and select another element in the timeline to select a range of elements.

    Please note that there is a known issue with moving multiple elements left or right with the arrow keys at the moment which will be fixed in the next few weeks. You can move multiple elements left or right by clicking and dragging with the mouse.


  • This is definitely not working for me. When I hold down the CTRL key (either CTRL key) and click on another element, only the second element is selected. I'm using Windows 8. 

    Are you sure this works? I have a backup PC (also Windows 8) would it be useful for me to install and test there?

  • Hi Jonathan,

    Sorry that you are still having a problem with this.

    Yes, I can confirm that this definitely works.

    Are you clicking on the element on the canvas or on the timeline at the bottom of the screen? 

    Also are you sure that you are holding down the ctrl key and not the shift key? If you hold down the shift key and click on the elements on the canvas you will see the behaviour that you describe.

    I am using windows 8 too.


  • Thanks for your quick reply Andy. I'm definitely holding down CTRL and not SHIFT. I'm clicking on the elements in the timeline (But I've tried clicking on the screen as well). I will install on my backup PC, to see if that isolates the issue.

  • Hi Jonathan

    Let me know how it goes with your other computer.


  • Hi Andy,

    It worked on my other computer, so I started doing some extensive testing on this feature and here is what I found.

    I have a scribe with multiple elements, including 

    a) the word "tomorrow", and 

    b) an image (jpg) of a man

    Whenever I clicked on the image of the man FIRST, and then attempted a multi-select, the multi-select would fail, and would fail on any element, in any scribe, until I closed VideoScribe.

    Whenever I clicked on the word tomorrow FIRST, the "multi-select" feature worked, and worked always, including when I clicked on the man.

    Then I saved my file with a new name, and now multi-select ALWAYS works, and I can no longer reproduce the bug.

    Thanks for your help.


  • Hi Jonathan,

    Thanks for doing some investigation.

    I tried to replicate but couldn't get the same thing to happen for me. So, this only happened before you saved the scribe?

    If you could let me know which font you used and if you could attach the jpg file I can investigate further as I would like to track this down.



  • Hi Andy,

    I just saved that scribe online, it's called CoverVideo323 (can you access), but truthfully I can't reproduce the bug now either. The man is the 7th element. The "Tomorrow" is easy to find. The font is FreightSans Black.

    This is a video we made several weeks ago, and once I re-saved in v2, the problem went away.


  • Jonathan,

    I have the same problem as you.  2.0 is HORRIBLY buggy and after a few minutes, the ability to multi-select will get buggy.  Also, you will not be able to drag and move slides around.  Your only option at this point is to exit the application and restart it.  Then work for a few minutes and repeat the process.  2.0 feels like an alpha release to me.

    C. Gomez

  • Hi Chola,

    Sorry that you have had problems with this.

    It would be useful to know exactly what you are doing with VideoScribe when you get this problem. Are you using your own images, the library images, really big scribes? I would like to be able to replicate the problem here as I have never had that issue.



  • Hi. I am completely unable to make multiple selections. I am running v1.3.31 on Win 7. I have tried both the left and right <ctrl> keys, plus various permutations involving <shift> and <alt>. I have tried selecting text before selecting an image, per Jonathan above.

    The "what's new" page at

    says that v1.3.31 does support multiple selections. 

    Any suggestions?


  • Hi Henry,

    Sorry that you are having a problem with this.

    Looking at when you signed up I think that you will be running version 1.3.26 which mistakenly reports itself as 1.3.31. If you look in Control Panel you will see the real version number. Apologies for any confusion there.

    We have version 2.0 available which does have the multiple select feature and it is available here



  • Thanks very much Andy, you were correct -- control panel showed that I was in fact running v1.3.26, and now that I've installed v2 I can at last multi-select  :-)

    BTW, it wasn't clear to me whether I should first manually uninstall v1.3.26 before installing v2, or whether I could just overwrite v2 over v1. (I manually uninstalled.) You should provide installation notes about that.

    Thanks again,

  • Hi Henry,

    It's good to hear that you are now able to multi-select.

    Thanks for your feedback about the installation - I will pass it on to the relevant people.

    You can install 2.0 with version 1 still installed or do as you did and uninstall. Uninstalling doesn't remove any of your scribes so you will not lose anything.


Login to post a comment