Imported images aren't working correctly

This article will outline some common issues that you may face when importing your own images

Symptoms

You may experience some issue when importing SVG (recommended), PNG, JPG or GIF images into VideoScribe such as: 

  • The image does not appear at all
  • The image does appear but you cannot save your work
  • VideoScribe does not draw the image and it appears instantly on the canvas

Cause

There are many reasons this issue could occur but the most common are:

  • The image has not been optimized for use within VideoScribe
  • The image has not been saved with the correct format settings
  • The image has become corrupted
  • VideoScribe may have problems reading a new image when the available memory is running at capacity or near capacity. It might not be the size of the image itself but the amount of memory used up by the scribe you are importing the image into. 

Workarounds

1. Optimize your images

You should optimize all images before you import them into VideoScribe. For bitmap (raster) images, (JPGs and PNGs) you should ideally be looking at image sizes of below 500KB. If you intend to import a lot of JPG and/or PNG images into the same scribe you should get the images as small as possible.

If you are importing your own SVG images, see the recommended save settings and the tips at the end of the article create your own images

2. Delete and re-import images

Sometimes an image gets corrupted. Try deleting the image from VideoScribe (and from your recent images in the image library) and importing it again. 

3. Reformatting images

If the problem persists, open the images in Paint (Windows) or Preview (Mac). 

  1. Open the image in your preferred program

  2. Select ‘File’ then ‘Save as’ or ‘File’ then ‘Export…’

  3. Save the image in a file type compatible with VideoScribe (JPEG or PNG)

  4. Import the image into VideoScribe again

If you have added an image and find that it is causing problems with the image library loading when you go to add another image, see the article Library images will not preview or load.

If you are experiencing difficulties with an image and cannot solve it yourself you can contact our Customer Success team directly. Please attach the image and include as much information as you can so we can look into it for you.