Lines get thicker when drawing is done

  • Sure. I've attached testoriginal.svg that evokes the line thickening behaviour and testoriginal kopie.svg that does not.



  • Thank you for attaching your images.

     testoriginal.svg appears to be more extreme than the usual line thickening that I am familiar with.

    However, your testoriginal kopie.svg  looks GREAT when saved to a video. Thank you for posting your results!

    -Mike (videoscribe user)

  • If your Inkscape doesn't have a section 'Scale' (it should be right under 'Custom size'), as an alternative edit the svg file itself in a text editor. Remove the viewBox attribute from the svg element (the root element of the file). This works equally well.

  • Thanks for your insights Joop.

    The 'Scale' option is new in version 0.92 of Inkscape so it will appear if you upgrade Inkscape.

  • When I open those files in Illustrator, the two drawings are very different in size. So it might also have to do with the size or line thickness of the drawing, not only viewbox. 

    Did someone found a solution already using Adobe Illustrator? thanks

  • If you are referring to the 2 test SVGs that Joop Ringelberg posted, I think it is to do with the size of the artboards and the width of the strokes.

    The one that looks small in Illustrator (original) has artboard dimensions of 114.29 by 107.69 pixels and the stroke width is 0.794 pixels. This one has a bad thickening issue.

    The larger one (kopie) has artboard dimensions of 800 by 800 pixels and the stroke width is 0.794 pixels. This one doesn't have a bad thickening issue.

    The strokes on the 'kopie' image look much thicker in Illustrator than they do in VideoScribe - both images seem to have the same stroke width in VideoScribe and import at roughly the same size.

    I would say that keeping the artboard around 800 x 800 pixels and making sure the stroke width is greater than 1 pixel should help to eliminate the thickening.

  • Hi ... Is there a final solution to the Line Thickening problem? I'm a beginner using PowerPoint and Autodesk Sketchbook to create my drawings, Inkscape to draw the transparent vector path over the top and Videoscribe to put it all together. I've tried many of the suggestions in this thread and still get the Line Thickening problem.  Any easy suggestions? Thanks. Tom 

  • You should probably attach one of your problem images for specific feedback if you are seeing thickening with that SVG technique.

    -Mike (videoscribe user)

  • Regarding the Line Thickening ... here are my files ... Very curious to know what I'm doing wrong... The work flow in this image... I drew it in PowerPoint, saved the file as a png, imported it into Inkscape, put the png in layer 1, drew an invisible vector path with 6 px thickness on layer 2, saved it as an svg, imported it into Videoscribe and ... I've got the thin / fat line problem :-(   

    I really need to fix this as the ability to easily 'draw' my images on screen is the main reason I purchased videoscribe. 

    Thanks. Tom 

  • Hi,

    In this case, it is not the problem being discussed in this thread, although it might look similar.

    I've opened the SVG and I see that your invisible vector path is much too thin to reveal the png properly. I changed the opacity of the path to 100% opaque so you can see what I mean:


    Your stroked path has to completely cover the background image to work correctly. Edit your SVG make the stroke thick enough to cover the PNG completely then change the stroke opacity to 0% again and save it.

    (By the way, 871 KB is too big for a file like this. You should probably scale your PNG smaller before importing it into inkscape to get the file size down under 200 or 100 kb. Unless it is going to be a huge background in which case maybe a larger file size may be necessary.)

    Hope that makes sense,

    -Mike (videoscribe user)

  • Thanks Mike ... great help ... strange, because when I open the vector path it covers the image completely ... anyway I'll go back and play and reduce the image size.  Tom 

  • When you save the SVG it may be affecting the settings. If you are opening the inkscape file it may not look the same as if you open the SVG file.

    Also (copied from another thread)  It, is important that you use "File>Save as> SVG"  (or the closest variation of that option in your program of choice). In inkscape , I think it is "file>save as>plain SVG".  Do NOT use any save menu options with the word "export" or "optimized" or "compressed". Optimized SVGs may contain formatting that causes problems in videoscribe.

  • Mike... You're a hero! So simple ... "save as - plain SVG" ... Many thanks for your help. Tom 

  • YAY! Thank you for sharing your results.

Login to post a comment