Not able to import fonts in Videoscribe new version 3.6

  • I am not able to import any fonts in this version of this software. If I have purchased any font and want to use it in Videoscribe I should be able to use it. Why this important feature has been removed?


    Please help! I am having so much problem because of this.

  • The font system is a completely new system from the previous versions which means the following:

    • In version 3.6, you will be able to use pre-installed Google fonts which are listed in the add text element menu. Please use version 3.5.2 if you wish to use your own imported fonts
    • You can still edit the contents of any fonts that already exist in your scribes, prior to 3.6
    • Version 3.6 is compatible with 64-bit desktop machines. From version 3.6 onwards we will only support 64-bit machines on VideoScribe. If you have a 32-bit machine, please install version 3.5.2
    • Saving a scribe file in version 3.6 will upgrade your existing scribe files to the new font system. This means that you cannot use 3.6 scribe files in previous versions



    If you have any questions regarding these changes please check our Instant Answers

  • This is crazy!


    I need to use custom fonts that are expensive to buy and are on brand and then I can't use them on the new version of the software. I also can't just 'USE' a 32bit version as the new mac pro only runs 64 bit content. Also because I didn't know about the change, all of my old scribes now wont work on the old font system that I need it to.


    This needs to be addressed ASAP. The ability to use custom fonts is a requirement for any media creating software. This is such a horrible oversight. 

    Adding to this the help on the website mentions nothing of this new limitation. Is it because SPARKOL knows that this is a horrible decision but chose to do it anyway?


    Just awful

  • Hi Tiu

    The update to the Google font system has allowed for improved customisation, adjustable font weight, support for more languages and most importantly an improved quality of the characters displayed on the canvas.

    As mentioned previously, you can still use your own fonts in version 3.5.

    As you are using a Mac, the x32 bit version will not be applicable to you as this is only a requirement for Windows users, you can simply download and install the Mac OS .dmg file.

    I'm assuming you meant all of my old scribes now wont work on the 'new' font system?

    Your projects will still work as usual and display your text from the old font system, you just won't be able to add new text elements that use the old fonts.

    If you check the instant answer on historic fonts posted previously it will provide you with the steps on how to do this.

    Far from a limitation, the improvement of language support alone has been one of the most requested features on our forums that can be expanded due to the implementation of this new system.

Login to post a comment