Morph mode not available on imported images in v3.9 (VISC-1249)

  • Hello,

    Recently, I upgraded from version 3.7 to 3.9, however, morph mode is not available after upgrading. Before upgrading, at version 3.7, morph mode is available. Kindly refer to my attachment for more detail. Please help. Thanks.

  • Morph is working in VideoScribe v3.9, it'll work on all the images in our Library and any SVG images you create which follow the guidelines we set out on our Images: Creating your own help page.

    The issue with the images you have created is that they contain no strokes. VideoScribe follow strokes to draw an image and morph only works on strokes (it removes fills and readds them after the morph animation is finished).

    We had set-up draw and morph to consider the vector lines on fills as a stroke where no strokes were present for the purpose of making a decent stab at drawing an image made that way. It's still available on draw but looks quite messy, it looked even worse on morph so has been removed.

    So the answer to this is to use strokes for the lines of your image, and just use fills for the colour. That way you images will draw cleanly like the images in our Library, and also still morph (it's a win win).

  • Hi Barry,

    Thank you for your explanation. I've known the way to create SVG file as Videoscribe tutorial, but that way wasted my time to draw each strokes by pen tool, then fill in the color one by one. I have one more question, why morph mode can work in version 3.7.3103 with the way I created in Illustrator? You can try to use 2 SVG files in my previous attachment in this ticket to try in version 3.7.3103 and version 3.90, and see the difference. 2 SVG files I created can morph in version 3.7.3103 but version 3.90 is impossible.

    Convert from any images to SVG file by my way, just take around 1 minute. Draw strokes by pen tool to make SVG file, will take more time.

    If the version 3.90 couldn't solved with morph mode as I'm facing, then I'll back to 3.7.3103. With this version, I won't waste my time to make each strokes by pen tool.

    If you have any idea to help me solving this problem, then I'm glad to use version 3.9 with new features in text animation.

    Thank you!


  • Hello Mike,

    I've looked into the VideoScribe Images, and seen so many paths there. Even my own image is less paths than VideoScribe images, but morph is not available in version 3.9.0. Why it could be?..

    Could you open my SVG file in Illustrator and have a look? Video attached.



    (17.5 KB)
  • Hey Thanh,

    As I said, there has been a change in v3.9 which means images without strokes will not morph. We had a fallback in place in previous versions which would make the best of an image without strokes. It's still available on draw but looks quite messy, it looked even worse on morph so has been removed. 

    The image you have picked from the library as an example is a group of people so it's got a lot of detail in it and a lot of vector paths. VideoScribe will only be drawing/morphing the top 2 layers there though which are strokes. All the colour fills in the other layers will be will be ignored by the hand. As you can see below, this image Morph's in v3.9.

  • Hello, I have done some more digging and I have got my answer on this post wrong so correcting myself. There is a bug in v3.9 of VideoScribe with morph and all imported SVGs (even those with strokes) will not have the option of being the object you 'morph to'. If you have a Library image to as the 'morph to' option you will be able to 'morph from' an imported image. The bug has been reported to the development team (ref VISC-1249) and we'll keep you updated on when a fix can be expected. 

    If you really need to morph imported images in the meantime please download v3.8.500 from the previous versions section of

  • Hello Barry,

    Thanks for your response.


  • Just to let you know we released v3.9.5 last week which contains a fix for this bug

  • I've tried v3.9.5 and it's working well. Thanks, Barry.

Login to post a comment